Kali Linux 1.06 install Airprobe GSM-Receiver fehlermeldung beim befehl make

  • Ich habe Kal Linux 1.06 (Debian) neu installiert Gnu-Radio ist ja schon vorhanden nun möchte ich auch Airprobe GSM-Receiver installieren allerdings bekomme ich immer eine fehlermeldung .
    ich gehe wie folgt vor


    sudo apt-get -y install git-core autoconf automake libtool g++ python-dev swig libpcap0.8-de


    mkdir sdr
    cd sdr


    git clone git://git.osmocom.org/libosmocore.git
    cd libosmocore
    autoreconf -i
    ./configure
    make
    sudo make install
    sudo ldconfig
    cd ..


    3. gsmdecode:
    git clone git://svn.berlin.ccc.de/airprobe
    cd airprobe/gsmdecode/
    ./bootstrap
    ./configure
    make
    cd..


    4. gsm-receiver:
    cd airprobe/gsm-receiver/
    ./bootstrap
    ./configure
    make


    sobald ich den befehl make ausführen möchte kommt folgende fehlermeldung


    ./Timeval.h: In function 'void msleep(long int)':
    ./Timeval.h:32:49: error: 'usleep' was not declared in this scope
    In file included from GSMCommon.cpp:23:0:
    GSMCommon.h: In function 'void GSM::sleepFrames(unsigned int)':
    GSMCommon.h:62:36: error: 'usleep' was not declared in this scope
    GSMCommon.h: In function 'void GSM::sleepFrame()':
    GSMCommon.h:66:29: error: 'usleep' was not declared in this scope
    make[5]: *** [GSMCommon.lo] Fehler 1
    make[5]: Leaving directory `/root/sdr/airprobe/gsm-receiver/src/lib/decoder/openbtsstuff'
    make[4]: *** [all-recursive] Fehler 1
    make[4]: Leaving directory `/root/sdr/airprobe/gsm-receiver/src/lib/decoder'
    make[3]: *** [all-recursive] Fehler 1
    make[3]: Leaving directory `/root/sdr/airprobe/gsm-receiver/src/lib'
    make[2]: *** [all-recursive] Fehler 1
    make[2]: Leaving directory `/root/sdr/airprobe/gsm-receiver/src'
    make[1]: *** [all-recursive] Fehler 1
    make[1]: Leaving directory `/root/sdr/airprobe/gsm-receiver'
    make: *** [all] Fehler 2
    root@kali:~/sdr/airprobe/gsm-receiver#



    muss ich um airprobe zum laufen zu bekommen den kompletten gnu script ausführen.
    wie schon erwähnt Linux ist frisch aufgesetzt Gnu Radio ist ja schon von Kali aus drauf ver 3.6.5.1
    apt-get update
    apt-get dist-upgrade

  • Das liegt meistens daran das libosmocore faslch installiert ist wichtig ist beim installiere das gnu arm der befehl
    export PATH=$PATH:/root/libosmocore/gnu-arm-toolchain/install/bin


    ausgeführt wird.